Click to Open in a New Window

Show Disclaimer
USA
Call Toll Free: 1-855-274-4934

What are the system requirements of the Just2Trade trading platform?

Our trading platform is compatible with Microsoft OS XP and Mac OS version 10.4. You will need a web browser that is Cookie, Java, JavaScript enabled, such as IE 6.0 or higher, Netscape 7.2 or higher, or Firefox for Mac version 3 and higher. The following platforms are not currently supported: IE 5 and lower, Netscape 6.0 and lower, WebTV, and Opera.

Another questions

<